网站建设语言 PHP 5.6和7.0将停止安全补丁更新

PHP 5.6和7.0,作为所有php语言开发的网站57.1%的基础的脚本语言将在2018年12月停止接收安全更新。在该日期之后,不会为这些版本的PHP发布安全补丁,从而使这些网站不那么安全。 这可能意味着流量损失以及在发生漏洞时仍使用旧版PHP的WordPress网站的排名噩梦。 此图显示了使用PHP 5.6和7.0的站点百分比。有些人担心超过三分之一的WordPress网站使用5.6。 什么是PHP? PHP是一种支持创建网站的脚本语言。有不同的版本。每个版本都代表了以前版本的改进。在创建每个版本时,软件(如WordPress)会更新,以便能够利用最新的性能改进。 安全更新何时结束? PHP 5.6的安全更新将于2018年12月31日结束。 PHP 7.0的安全更新和补丁将于2018年12月3日结束。 此表显示PHP 5.6和7.0何时不再接收安全更新。 有多少WordPress网站面临风险? 根据WordPress官方发布的统计数据,57.1%的WordPress网站运行这些过时的PHP版本。 为什么安全支持结束? 每个版本的安全支持计划持续有限的年限,直到达到所谓的生命终结(EOL)。此时,即使发现漏洞,也不会再为其创建安全性改进。 根据官方PHP网站,这是EOL的意思: “不再支持的版本。此版本的用户应尽快升级,因为他们可能会遇到未修补的安全漏洞。“ 所有网站都需要升级到最新版本,否则可能会受到黑客攻击。 如果您无法更新PHP怎么办? 所有未能升级到最新版PHP的网站都将不安全,并且在版本5.6和7.0进入其生命周期(EOL)期后容易受到黑客攻击。这意味着即使发现了安全漏洞,也没有人会修补PHP版本中的漏洞。 此外,许多插件,主题和WordPress本身最终将停止使用这些版本的PHP。 如果您运行WordPress网站,最谨慎的操作是升级到最新版本的PHP。 如何识别正在使用的PHP版本? 最简单的方法是登录您的主机控制面板,找到一个专注于PHP的部分的链接。有一些在线工具可以告诉您,但最好直接登录控制面板并自行检查。 还有一些插件可以告诉您正在使用哪个版本。例如,  WordPress phpinfo()  插件是一个易于使用的插件,可以告诉你WordPress网站使用的是哪个版本的PHP。一旦您知道正在运行的是哪个版本的PHP,就可以删除该插件。 或者,您可以致电您的托管服务提供商的支持,并寻求帮助,以确定您的网站使用的版本以及如何升级的说明。 如何将PHP从5.6 / 7.0升级到最新版本 步骤1 – 备份站点备份 WordPress站点非常重要。最简单的方法是使用UpDraftPlus插件。 第2步 – 检查插件兼容性 确保所有插件都已更新到最新版本。此外,更新应该在过去几个月内发生,不超过一年。 如果插件在很长一段时间内没有更新,请访问插件的作者网页并验证插件是否与最新版本的PHP(PHP 7.2)兼容。 如果插件不兼容,那么切换到最流行且最近更新的插件,它执行相同的操作。你真的不应该运行任何与最新版本不兼容的插件。维护不良的插件可能存在安全风险。 步骤3 – 升级PHP版本 登录到您的Web主机控制面板,找到PHP部分并升级您网站的PHP版本。如果这很困难,请联系您的网络托管支持寻求帮助。 使安全成为您的SEO过程的一部分 安全问题通常不是SEO的一部分。SEO主要关注有助于排名的改进。 但是,一旦网站遭到黑客攻击并且搜索流量消失,安全性就会迅速成为搜索引擎优化的噩梦。那么为什么要等到你的网站被黑客入侵以增加你的SEO工具包的安全性?为您的SEO例程增加安全性,避免流量丢失的危机。搜索引擎优化与保留流量同样重要。

友情提示:点赞熊源码网http://www.dianzanxiong.com点赞熊源码网 » 网站建设语言 PHP 5.6和7.0将停止安全补丁更新
分享到:
赞(0)
广告位820*80